]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: 1 more "build-dependency" for the website
[neurodebian.git] / Makefile
index a2061681f261f5193fd74a3a805186d76c63fae7..644d8b0bea1f3ee26c33e0d42bb5a465306a9667 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,8 +4,8 @@ WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
-BIGMESS_OPTS = -c neurodebian_repo.cfg
-BIGMESS_CMD = PYTHONPATH=.:../bigmess:$(PYTHONPATH) ../bigmess/bin/bigmess
+BIGMESS_OPTS = -c neurodebian.cfg
+BIGMESS_CMD = PYTHONPATH=.:3rd/bigmess:$(PYTHONPATH) 3rd/bigmess/bin/bigmess
 BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
 
 # Lentghy one due to updatedb
@@ -13,6 +13,12 @@ all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
 refresh: upload-website-stamp mirmon
 
+website-build-depends:
+       : # Python modules
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian python-html5lib
+       : # JavaScripts
+       sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
+
 
 pics:
        $(MAKE) -C artwork
@@ -52,9 +58,10 @@ source-stamp:
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
        touch $@
 
-
-updatedb:
+cachefiles:
        $(BIGMESS) cachefiles -f
+
+updatedb: cachefiles
        $(BIGMESS) updatedb
        -rm source-stamp
 
@@ -78,5 +85,5 @@ mirmon:
        cat $(WWW_UPLOAD_URI_STATIC)/{index-header,mirrors-status,index-trailer}.ihtml \
         >| $(WWW_UPLOAD_URI)/mirrors-status.html
 
-.PHONY: removedb removecache updatedb upload-website clean distclean pics html mirmon
+.PHONY: removedb removecache cachefiles updatedb upload-website clean distclean pics html mirmon