]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: 1 more "build-dependency" for the website
[neurodebian.git] / Makefile
index 5f4732e1a8b1e697b2d04338beb6d4ac8c582f93..644d8b0bea1f3ee26c33e0d42bb5a465306a9667 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -4,7 +4,7 @@ WWW_DIR = build/html/
 
 WWW_UPLOAD_URI_STATIC=$(WWW_UPLOAD_URI)/_static
 
-BIGMESS_OPTS = -c neurodebian_repo.cfg
+BIGMESS_OPTS = -c neurodebian.cfg
 BIGMESS_CMD = PYTHONPATH=.:3rd/bigmess:$(PYTHONPATH) 3rd/bigmess/bin/bigmess
 BIGMESS = $(BIGMESS_CMD) $(BIGMESS_OPTS)
 
@@ -13,6 +13,12 @@ all: updatedb upload-website mirmon
 # Quick one -- just rebuilds html if new changes and adjusts the status of the mirrors
 refresh: upload-website-stamp mirmon
 
+website-build-depends:
+       : # Python modules
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian python-html5lib
+       : # JavaScripts
+       sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
+
 
 pics:
        $(MAKE) -C artwork