]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Exclude debian-local also from being removed from n.d.n
[neurodebian.git] / Makefile
index fb0bc49bf6f00a19901ab1014ee0e9ff7546838f..5fec98bba7d6221f77d3a203bcc10a91a0756587 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,6 +12,7 @@ pics:
 html: pics source
        rsync -rvlhp sphinx/ build/src
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
 
 clean:
@@ -55,7 +56,7 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html