]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Exclude debian-local also from being removed from n.d.n
[neurodebian.git] / Makefile
index 73c66be9619d1b54bd5bc1304dcb256f03f4d23a..5fec98bba7d6221f77d3a203bcc10a91a0756587 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,55 +1,62 @@
-# old location
-#WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
-# brand new fancy one
-WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
-WWW_DIR = build/html
+#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
 
-all: html
-
-prep:
-       if [ ! -d build ]; then mkdir build; fi
-       rsync -rvlhp sphinx/ build/src
+all: updatedb upload-website
 
 
 pics:
        $(MAKE) -C artwork
 
 
-html: html-stamp
-html-stamp: pics prep source
-       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
-       touch $@
+html: pics source
+       rsync -rvlhp sphinx/ build/src
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
 
 clean:
-       -rm -rf build
+       -rm html-stamp source-stamp
        $(MAKE) -C artwork clean
 
 
-
 distclean: clean
-       -rm -rf cache
+       -rm -rf build
 
 
 source: source-stamp
 source-stamp: build/db.db
-       tools/reblender generate \
-               --cfg debneuro.cfg \
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
-               --pkgaddenum pkgs
+               --pkgaddenum pkgs \
+               commandisirrelevant
        rm -f html-stamp
        touch $@
 
 
+removecache:
+       -rm -rf build/cache
+
+removedb:
+       -rm build/db.db
+
+
+updatedb: removedb removecache build/db.db
+
+
 build/db.db:
        mkdir -p build
-       tools/reblender refreshdb \
-               --cfg debneuro.cfg \
-               --db build/db.db
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               updatedb
+       -rm source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR)/* $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html
 
-.PHONY: prep