]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Put icon links to extracts from DSCs (README, changelog, copyright)
[neurodebian.git] / Makefile
index 88b9e1be12b76d2f03655040ec14dea14edb8149..4f37cf71ae3b7012393a60c6a02db4bc7fabd198 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -26,12 +26,13 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp:
+source-stamp: build/db.db
        PYTHONPATH=. python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
@@ -57,7 +58,9 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html