]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Put icon links to extracts from DSCs (README, changelog, copyright)
[neurodebian.git] / Makefile
index 5fec98bba7d6221f77d3a203bcc10a91a0756587..4f37cf71ae3b7012393a60c6a02db4bc7fabd198 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,6 +11,7 @@ pics:
 
 html: pics source
        rsync -rvlhp sphinx/ build/src
+       cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
@@ -31,6 +32,7 @@ source-stamp: build/db.db
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
@@ -40,7 +42,7 @@ removecache:
        -rm -rf build/cache
 
 removedb:
-       -rm build/db.db
+       -rm -f build/db.db
 
 
 updatedb: removedb removecache build/db.db
@@ -52,11 +54,13 @@ build/db.db:
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
-       -rm source-stamp
+       -rm -f source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html