]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge branch 'master' of git://git.debian.org/git/pkg-exppsy/neurodebian
[neurodebian.git] / Makefile
index 97e75699974e13822046208e27d457fbfd6db8a0..4b9e35a7c432e465bdc0be57ec29b89b60395f49 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,15 +9,18 @@ pics:
        $(MAKE) -C artwork
 
 
-html: pics
+html: pics source
        rsync -rvlhp sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
+       cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
+       cp -r build/src/lists $(WWW_DIR)/
+       cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
 
 
 clean:
-       -rm html-stamp source-stamp
+       -rm html-stamp source-stamp upload-website-stamp
        $(MAKE) -C artwork clean
 
 
@@ -27,11 +30,12 @@ distclean: clean
 
 source: source-stamp
 source-stamp: build/db.db
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
+               --extracts /home/www/neuro.debian.net/www/debian/extracts \
                commandisirrelevant
        rm -f html-stamp
        touch $@
@@ -49,7 +53,7 @@ updatedb: removedb removecache build/db.db
 
 build/db.db:
        mkdir -p build
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
@@ -57,7 +61,15 @@ build/db.db:
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete \
+        --exclude=debian --exclude=debian-local --exclude=_files \
+        --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       : # Touch stamp here so we get it updated on every upload
+       touch $@-stamp
+
+# call upload iff .git/index was modified, i.e. new changes got pulled in
+upload-website-stamp: .git/index
+       $(MAKE) upload-website
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html