]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge branch 'master' of git.debian.org:/git/pkg-exppsy/neurodebian
[neurodebian.git] / Makefile
index 76ca1c270e7008628db9f03b9f2a363b9e2924bd..4b9e35a7c432e465bdc0be57ec29b89b60395f49 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,7 +20,7 @@ html: pics source
 
 
 clean:
-       -rm html-stamp source-stamp
+       -rm html-stamp source-stamp upload-website-stamp
        $(MAKE) -C artwork clean
 
 
@@ -30,7 +30,7 @@ distclean: clean
 
 source: source-stamp
 source-stamp: build/db.db
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
@@ -53,7 +53,7 @@ updatedb: removedb removecache build/db.db
 
 build/db.db:
        mkdir -p build
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
@@ -62,8 +62,14 @@ build/db.db:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files --exclude=survey \
+        --exclude=debian --exclude=debian-local --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       : # Touch stamp here so we get it updated on every upload
+       touch $@-stamp
+
+# call upload iff .git/index was modified, i.e. new changes got pulled in
+upload-website-stamp: .git/index
+       $(MAKE) upload-website
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html