]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Adding robots.txt to be installed to avoid traversing of debian/
[neurodebian.git] / Makefile
index a65b6d16e54c97b9b3553e867036032c8fec3677..3e2ceafff8530799add6ebbbfd04fcd25276b1d0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,40 +1,62 @@
+#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
 
-WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
-WWW_DIR = build/html
+all: updatedb upload-website
 
 
-prep:
-       mkdir -p build/src
-       cp -r sphinx/* build/src
+pics:
+       $(MAKE) -C artwork
 
 
-html: prep source
-       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
+html: pics source
+       rsync -rvlhp sphinx/ build/src
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
 
 clean:
-       -rm -rf build
+       -rm html-stamp source-stamp
+       $(MAKE) -C artwork clean
 
 
 distclean: clean
-       -rm -rf cache
+       -rm -rf build
 
 
-source:
-       ./reblender generate \
-               --cfg debneuro.cfg \
+source: source-stamp
+source-stamp: build/db.db
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
-               --pkgaddenum pkgs
+               --pkgaddenum pkgs \
+               commandisirrelevant
+       rm -f html-stamp
+       touch $@
+
+
+removecache:
+       -rm -rf build/cache
+
+removedb:
+       -rm build/db.db
 
 
-refresh-db:
+updatedb: removedb removecache build/db.db
+
+
+build/db.db:
        mkdir -p build
-#      rm -f build/db.db
-       ./reblender refreshdb \
-               --cfg debneuro.cfg \
-               --db build/db.db
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               updatedb
+       -rm source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+