]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Adding robots.txt to be installed to avoid traversing of debian/
[neurodebian.git] / Makefile
index 45071d87ba04c3caa28fe5dc1612f02c1d316e9a..3e2ceafff8530799add6ebbbfd04fcd25276b1d0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1,42 +1,62 @@
+#WWW_UPLOAD_URI = neuro.debian.net:/home/www/neuro.debian.net/www
+WWW_UPLOAD_URI = ../www
+WWW_DIR = build/html/
 
-WWW_UPLOAD_URI = elrond:/home/hanke/public_html/archive
-WWW_DIR = build/_build/html
+all: updatedb upload-website
 
 
-prep:
-       mkdir -p build/src
-       cp -r sphinx/* build/src
+pics:
+       $(MAKE) -C artwork
 
 
-html: prep update-db
-       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build
+html: pics source
+       rsync -rvlhp sphinx/ build/src
+       cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
+       mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
 
 
 clean:
+       -rm html-stamp source-stamp
+       $(MAKE) -C artwork clean
+
+
+distclean: clean
        -rm -rf build
 
 
-update-db:
-#              -r http://apsy.gse.uni-magdeburg.de/debian/dists/lenny/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/squeeze/Release \
-#      rm -f build/db.db
-       ./reblender \
+source: source-stamp
+source-stamp: build/db.db
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
                --pkgaddenum pkgs \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/dapper/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/gutsy/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/hardy/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/intrepid/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/etch/Release \
-               -r http://apsy.gse.uni-magdeburg.de/debian/dists/sid/Release \
-               -t svn://svn.debian.org/blends/projects/med/trunk/debian-med/tasks/imaging \
-               -t svn://svn.debian.org/blends/projects/med/trunk/debian-med/tasks/imaging-dev \
-               -t svn://svn.debian.org/blends/projects/science/trunk/debian-science/tasks/neuroscience-cognitive \
-               -f fsl-doc -f fslview-doc -f fsl-atlases -f fsl-possum-data \
-               -f fsl-first-data -f fsl-feeds \
-               -p svn://svn.debian.org/blends/projects/science/trunk/debian-science/tasks/neuroscience-cognitive
+               commandisirrelevant
+       rm -f html-stamp
+       touch $@
+
+
+removecache:
+       -rm -rf build/cache
+
+removedb:
+       -rm build/db.db
+
+
+updatedb: removedb removecache build/db.db
+
+
+build/db.db:
+       mkdir -p build
+       PYTHONPATH=. python neurodebian/dde.py \
+               --cfg neurodebian.cfg \
+               --db build/db.db \
+               updatedb
+       -rm source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+
+.PHONY: removedb removecache updatedb upload-website clean distclean pics html
+