]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
ENH: sort versions and provide colors to group debian/ubuntus in popcon plot
[neurodebian.git] / Makefile
index de232c7f9ba364e6fdb7691eb0ad89497e3be0b1..33f54bae0149a1f47a02571e24b9c0e0a2b95b85 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -15,7 +15,7 @@ refresh: upload-website-stamp mirmon
 
 website-build-depends:
        : # Python modules
-       sudo apt-get install python-sphinx python-argparse python-xdg python-debian
+       sudo apt-get install python-sphinx python-argparse python-xdg python-debian python-html5lib
        : # JavaScripts
        sudo apt-get install libjs-jquery-easing libjs-jquery-mousewheel libjs-jquery-fancybox
 
@@ -48,14 +48,19 @@ distclean: clean
 
 
 source: source-stamp
-source-stamp: 
+source-stamp:
        mkdir -p build/src/pkgs/
        mkdir -p build/src/lists/
+       mkdir -p build/src/_static/
        mkdir -p build/src/pkglists/
        $(BIGMESS) mkpkgs  -d build/src/pkgs/
        $(BIGMESS) mkaptcfgs -d build/src/lists/
+       $(BIGMESS) mkmirrorsstat -d build/src
        $(BIGMESS) mkrepocfg > build/src/sources_lists
        $(BIGMESS) mkpkgtocs -d build/src/pkglists > build/src/pkgs.rst
+       cp 3rd/nvd3/*.min.js build/src/_static/
+       cp 3rd/nvd3/lib/d3*.min.js build/src/_static/
+       cp 3rd/nvd3/src/nv*.css build/src/_static/
        touch $@
 
 cachefiles: