]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
1 new picture into coffee art collection
[neurodebian.git] / Makefile
index 94886961acd0c1e30496000cbcbebd310c1afe95..2d6b52360da01300509df06dc7a325e548219dc5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -16,6 +16,7 @@ html: pics source
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
        cp -r build/src/lists $(WWW_DIR)/
+       cp -r sphinx/survey/2011/figures/* $(WWW_DIR)/_images/
 
 
 clean:
@@ -29,7 +30,7 @@ distclean: clean
 
 source: source-stamp
 source-stamp: build/db.db
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                --outdir build/src \
@@ -52,7 +53,7 @@ updatedb: removedb removecache build/db.db
 
 build/db.db:
        mkdir -p build
-       PYTHONPATH=. python neurodebian/dde.py \
+       PYTHONPATH=.:$(PYTHONPATH) python neurodebian/dde.py \
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
@@ -61,7 +62,7 @@ build/db.db:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files --exclude=survey \
+        --exclude=debian --exclude=debian-local --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html