]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
-f for rm's so cronjob is silent
[neurodebian.git] / Makefile
index 3e2ceafff8530799add6ebbbfd04fcd25276b1d0..2899020bdf55682393835b43ec6c17c0416008db 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -40,7 +40,7 @@ removecache:
        -rm -rf build/cache
 
 removedb:
-       -rm build/db.db
+       -rm -f build/db.db
 
 
 updatedb: removedb removecache build/db.db
@@ -52,11 +52,11 @@ build/db.db:
                --cfg neurodebian.cfg \
                --db build/db.db \
                updatedb
-       -rm source-stamp
+       -rm -f source-stamp
 
 
 upload-website: html
-       rsync -rvzlhp --delete --exclude=debian --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
+       rsync -rvzlhp --delete --exclude=debian --exclude=debian-local --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
 
 .PHONY: removedb removecache updatedb upload-website clean distclean pics html