]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
General editing pass for the copyright format specification
[debian/debian-policy.git] / Makefile
index c3e6b4914d07f62b482fce8d9acbebd39a296189..1f3675cf0858e084c39ece76c4193305020fbe47 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,18 +2,16 @@ include debian/rules
 
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
-mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
 
-ifneq (,$(strip $(HAVE_ORG_EMACS)))
 %.txt: %.org
-       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
           --funcall org-export-as-ascii >/dev/null 2>&1
        test "$@" != "README.txt"  ||                            \
            perl -pli -e 's,./Process.org,Process.txt,g' $@
 %.html: %.org
        $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
           --funcall org-export-as-html-batch >/dev/null 2>&1
-endif
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -56,8 +54,7 @@ pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               libc6-migration.txt \
-               upgrading-checklist.html virtual-package-names-list.txt
+               libc6-migration.txt
              
 .PHONY: distclean
 distclean: