]> git.donarmstrong.com Git - debian/debian-policy.git/blobdiff - Makefile
Undo more spurious formatting changes
[debian/debian-policy.git] / Makefile
index b6c98f3330ce2c03dc366945dc19c3ceac7bcc6e..1f3675cf0858e084c39ece76c4193305020fbe47 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,16 @@ include debian/rules
 
 policy.sgml: version.ent
 menu-policy.sgml: version.ent
-mime-policy.sgml: version.ent
+perl-policy.sgml: version.ent
+
+%.txt: %.org
+       $(EMACS) --batch -Q -l ./README-css.el -l org -l org-ascii --visit $^ \
+          --funcall org-export-as-ascii >/dev/null 2>&1
+       test "$@" != "README.txt"  ||                            \
+           perl -pli -e 's,./Process.org,Process.txt,g' $@
+%.html: %.org
+       $(EMACS) --batch -Q -l ./README-css.el -l org --visit $^ \
+          --funcall org-export-as-html-batch >/dev/null 2>&1
 
 %.validate: %
        nsgmls -wall -gues $<
@@ -10,6 +19,11 @@ mime-policy.sgml: version.ent
 %.html/index.html: %.sgml
        LANG=C debiandoc2html $<
 
+%-1.html: %.sgml
+       LANG=C debiandoc2html -1 -b $*-1d $< && \
+        mv $*-1d.html/index.html $*-1.html && \
+        rmdir $*-1d.html
+
 %.html.tar.gz: %.html/index.html
        tar -czf $(<:/index.html=.tar.gz) $(<:/index.html=)
 
@@ -33,15 +47,14 @@ mime-policy.sgml: version.ent
 
 # convenience aliases :)
 html: policy.html/index.html
+html-1: policy-1.html
 txt text: policy.txt
 ps: policy.ps
 pdf: policy.pdf
 policy: html txt ps pdf
 
 leavealone :=  $(FHS_HTML) $(FHS_FILES) $(FHS_ARCHIVE) \
-               fhs-2.0.tar.gz fhs-changes-2.1.html \
-               fsstnd-1.2.txt.gz libc6-migration.txt \
-               upgrading-checklist.html virtual-package-names-list.txt
+               libc6-migration.txt
              
 .PHONY: distclean
 distclean: