]> git.donarmstrong.com Git - neurodebian.git/blobdiff - Makefile
Merge remote-tracking branch 'alioth/master' into newdesign
[neurodebian.git] / Makefile
index d0cf9896708f8bbe60677803e8ec947bd825a2cf..361dd1ea327b3aaa6a583b84e3c2b5cff0b53be5 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -22,6 +22,7 @@ html: pics source
        rsync -rvlhpt sphinx/ build/src
        cd artwork;     cp button_w200.png logo_tuned/fmri_w200.png ../build/src/_static; cd ..
        cp 3rd/jquery.livetwitter/jquery.livetwitter.min.js build/src/_static
+       cp neurodebian.cfg build/src/_static
        cd build/src && $(MAKE) html BUILDDIR=$(CURDIR)/build 2>&1
        ln -fs /usr/share/javascript build/html/
        mv $(WWW_DIR)/_static/robots.txt $(WWW_DIR)/
@@ -58,7 +59,7 @@ updatedb:
 
 upload-website: html
        rsync -rvzlhp --delete \
-        --exclude=debian --exclude=debian-local --exclude=_files \
+        --exclude=debian --exclude=debian-local --exclude=debian-devel --exclude=_files \
         --chmod=Dg+s,g+rw $(WWW_DIR) $(WWW_UPLOAD_URI)
        : # Touch stamp here so we get it updated on every upload
        touch $@-stamp