]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.spec
7041a22ba8da05436c6d7a93fface3af8da3081a
[lilypond.git] / make / out / lilypond.spec
1 %define info yes
2
3 Name: lilypond
4 Version: 1.3.146
5 Release: 1
6 License: GPL
7 Group: Applications/Publishing
8 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.146.tar.gz
9 # music notation software for.. ?
10 Summary: A program for printing sheet music.
11 URL: http://www.cs.uu.nl/~hanwen/lilypond
12 # rpm: 4.0: broken for -ta builds: rpm doesn't look in tarball for xpm
13 # Icon: lilypond-icon.xpm
14 BuildRoot: /tmp/lilypond-install
15 Prereq: tetex
16
17 # use keywords: music notation software
18 %description
19 LilyPond is a music typesetter.  It produces beautiful
20 sheet music using a high level description file as input.  LilyPond is
21 part of the GNU Project.
22
23 %package documentation
24 Summary: Prebuilt website containing all LilyPond documentation.
25 Group: Applications/Publishing
26 # BuildArchitectures: noarch
27
28 %description documentation
29
30 The documentation of LilyPond, both in HTML and PostScript.
31
32 %prep
33 %setup
34
35 %build
36
37 #
38
39 # DO NOT use % { configure } , it hardcodes all paths, runs libtool,
40 # so we can't do make prefix=/tmp/ install.
41
42 # In fact, do not take out the spaces between % and { , because RPM will gladly
43 # do a substitution anyway.
44
45 ./configure --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
46
47 make all
48
49 # urg
50 # %build documentation
51 # line 42: second %build
52 # ok, now make sure that lilypond package will succeed,
53 # even if documentation fails to build
54
55 make -C Documentation  || true
56 make web || true
57
58 %install
59
60
61
62 rm -rf $RPM_BUILD_ROOT
63 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
64
65 strip lily/out/lilypond midi2ly/out/midi2ly
66 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
67 %if info=="yes"
68 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
69 %endif
70
71
72
73 gzip -9fn $RPM_BUILD_ROOT%{_prefix}/man/man1/* || true
74
75
76
77
78 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
79 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
80 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
81
82 # urg
83 #%install documentation
84 #line 63: second %install
85 # again, make sure that main package installs even if doco fails
86 mkdir -p web/out
87 tar -C web -xzf out/web.tar.gz || true
88
89 %ifos cygwin
90 # urg, this symlink doesn't come through on cygwin
91 # this is the way symlinks work over there, let's fake one
92 rm -f $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
93 echo '!<symlink>c:\\texmf\\fonts\\tfm\\public\\cm' > $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
94 %{fix_suffixes}
95 %endif
96
97 %post
98
99 touch /tmp/.lilypond-install
100 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
101 %if info=="yes"
102 /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
103 %endif
104
105 %preun
106 %if info=="yes"
107 if [ $1 = 0 ]; then
108     /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
109 fi
110 %endif
111
112
113 %files
114 # hairy to hook it in (possibly non-existing) emacs
115 %doc lilypond-mode.el
116 %doc lilypond-font-lock.el
117
118 %ifnos cygwin
119 %{_prefix}/bin/abc2ly
120 %{_prefix}/bin/as2text
121 %{_prefix}/bin/convert-ly
122 %{_prefix}/bin/etf2ly
123 %{_prefix}/bin/lilypond
124 %{_prefix}/bin/ly2dvi
125 %{_prefix}/bin/midi2ly
126 %{_prefix}/bin/lilypond-book
127 %{_prefix}/bin/mup2ly
128 %{_prefix}/bin/musedata2ly
129 %{_prefix}/bin/pmx2ly
130 %else
131 %{_prefix}/bin
132 %endif
133
134 %if info=="yes"
135 %{_prefix}/info/lilypond.info.gz
136 %{_prefix}/info/lilypond-internals.info.gz
137 %endif
138
139 %{_prefix}/man/man1/abc2ly.1.gz
140 %{_prefix}/man/man1/as2text.1.gz
141 %{_prefix}/man/man1/convert-ly.1.gz
142 %{_prefix}/man/man1/etf2ly.1.gz
143 %{_prefix}/man/man1/lilypond.1.gz
144 %{_prefix}/man/man1/ly2dvi.1.gz
145 %{_prefix}/man/man1/midi2ly.1.gz
146 %{_prefix}/man/man1/lilypond-book.1.gz
147 %{_prefix}/man/man1/musedata2ly.1.gz
148 %{_prefix}/man/man1/mup2ly.1.gz
149 %{_prefix}/man/man1/pmx2ly.1.gz
150
151 %{_prefix}/share/lilypond/
152 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
153 # urg?
154 %{_prefix}/../etc/profile.d/lilypond.*
155
156 %files documentation
157 # this gets too messy...
158 # %doc input/*.ly
159 # verbatim include of input: list the directory without issuing a %dir 
160 %doc web/