]> git.donarmstrong.com Git - lilypond.git/blob - make/out/lilypond.spec
6595aa752d03cd283fa9da183e25f7deae7f010c
[lilypond.git] / make / out / lilypond.spec
1 Name: lilypond
2 Version: 1.3.91
3 Release: 1
4 Copyright: GPL
5 Group: Applications/Publishing
6 Source0: ftp.cs.uu.nl:/pub/GNU/LilyPond/development/lilypond-1.3.91.tar.gz
7 Summary: A program for printing sheet music.
8 URL: http://www.cs.uu.nl/~hanwen/lilypond
9 # Icon: lilypond-icon.gif
10 BuildRoot: /tmp/lilypond-install
11 Prereq: tetex
12
13 %description
14 LilyPond is a music typesetter.  It produces beautiful
15 sheet music using a high level description file as input.  LilyPond is
16 part of the GNU Project.
17
18 %package documentation
19 Summary: Prebuilt website containing all LilyPond documentation.
20 Group: Applications/Publishing
21 # BuildArchitectures: noarch
22
23 %description documentation
24
25 The documentation of LilyPond, both in HTML and PostScript.
26
27 %prep
28 %setup
29
30 %build
31
32 %{configure} --disable-checking --disable-debugging --enable-printing --prefix=%{_prefix} --disable-optimise --enable-shared
33
34 make all
35
36 ln -s %{_prefix}/share/texmf/fonts/tfm/public/cm/ tfm
37
38 # urg
39 # %build documentation
40 # line 42: second %build
41 # ok, now make sure that lilypond package will succeed,
42 # even if documentation fails to build
43 make -C Documentation  || true
44 make htmldoc || true
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 mkdir -p $RPM_BUILD_ROOT/tmp/lilypond-rpm-doc
49
50 strip lily/out/lilypond midi2ly/out/midi2ly
51 make prefix="$RPM_BUILD_ROOT%{_prefix}" install
52 # gzip -9fn $RPM_BUILD_ROOT%{_prefix}/info/* || true
53
54 mkdir -p $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d
55 cp buildscripts/out/lilypond-profile $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.sh
56 cp buildscripts/out/lilypond-login $RPM_BUILD_ROOT%{_prefix}/../etc/profile.d/lilypond.csh
57
58 # urg
59 #%install documentation
60 #line 63: second %install
61 # again, make sure that main package installs even if doco fails
62 mkdir -p htmldocs/out
63 tar -C htmldocs -xzf out/htmldoc.tar.gz || true
64 mkdir -p out/examples/
65 tar -cf - input/  | tar -C out/examples/ -xf- || true
66
67 %ifos cygwin
68 # urg, this symlink doesn't come through on cygwin
69 # this is the way symlinks work over there, let's fake one
70 rm -f $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
71 echo '!<symlink>c:\\texmf\\fonts\\tfm\\public\\cm' > $RPM_BUILD_ROOT%{_prefix}/share/lilypond/cmtfm
72 %{fix_suffixes}
73 %endif
74
75 %post
76
77 touch /tmp/.lilypond-install
78 rm `find /var/lib/texmf -name 'feta*pk -print' -or -name 'feta*tfm -print'` /tmp/.lilypond-install
79 # /sbin/install-info %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
80
81 %preun
82 if [ $1 = 0 ]; then
83  true #   /sbin/install-info --delete %{_prefix}/info/lilypond.info.gz %{_prefix}/info/dir || true
84 fi
85
86
87 %files
88 # hairy to hook it in (possibly non-existing) emacs
89 %doc lilypond-mode.el
90
91 %ifnos cygwin
92 %{_prefix}/bin/abc2ly
93 %{_prefix}/bin/etf2ly
94 %{_prefix}/bin/musedata2ly
95 %{_prefix}/bin/pmx2ly
96 %{_prefix}/bin/convert-mudela
97 %{_prefix}/bin/mudela-book
98 %{_prefix}/bin/ly2dvi
99 %{_prefix}/bin/lilypond
100 %{_prefix}/bin/midi2ly
101 %else
102 %{_prefix}/bin
103 %endif
104
105 %{_prefix}/man/man1/midi2ly.1
106 %{_prefix}/man/man1/lilypond.1
107 %{_prefix}/man/man1/mudela-book.1
108 %{_prefix}/man/man1/ly2dvi.1
109 %{_prefix}/man/man1/convert-mudela.1
110 %{_prefix}/share/lilypond/
111 %{_prefix}/share/locale/*/LC_MESSAGES/lilypond.mo
112 # urg?
113 %{_prefix}/../etc/profile.d/lilypond.*
114
115 %files documentation
116 # this gets too messy...
117 # %doc input/*.ly
118 # verbatim include of input: list the directory without issuing a %dir 
119 %doc htmldocs/
120 %doc out/examples/
121 %doc mutopia/