]> git.donarmstrong.com Git - deb_pkgs/autorandr.git/blob - contrib/packaging/rpm/autorandr.spec
Fixed python2 build problem
[deb_pkgs/autorandr.git] / contrib / packaging / rpm / autorandr.spec
1 %define name autorandr
2 %define version 1.10.1
3 %define release 1
4
5 # pmutils
6 %define use_pm_utils 1
7 %if 0%{?fedora} > 22
8 %define use_pm_utils 0
9 %endif
10 %if 0%{?rhel} > 7
11 %define use_pm_utils 0
12 %endif
13
14 # python 2 or 3
15 %define py_ver 3
16 %if 0%{?rhel}
17 %define py_ver 2
18 %endif
19
20 Summary: Automatically select a display configuration based on connected devices
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}%{?dist}
24 Source0: https://github.com/phillipberndt/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
25 License: GPLv3
26 Group: Development/Libraries
27 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
28 Prefix: %{_prefix}
29 BuildArch: noarch
30 Vendor: Phillip Berndt <phillip.berndt@googlemail.com>
31 Url: https://github.com/phillipberndt/autorandr
32 Requires: python%{py_ver}
33 %if 0%{?use_pm_utils}
34 Requires:       pm-utils
35 %endif
36 %{?systemd_ordering}
37 BuildRequires: bash-completion
38 BuildRequires: python%{py_ver}-devel
39 BuildRequires: systemd
40 BuildRequires: udev
41 %if %{py_ver} == 2
42 BuildRequires: python3-devel
43 %endif
44
45
46 %description
47 # autorandr
48
49 Automatically select a display configuration based on connected devices
50
51 ## Branch information
52
53 This is a compatible Python rewrite of
54 [wertarbyte/autorandr](https://github.com/wertarbyte/autorandr). Contributions
55 for bash-completion, fd.o/XDG autostart, Nitrogen, pm-utils, and systemd can be
56 found under [contrib](contrib/).
57
58 The original [wertarbyte/autorandr](https://github.com/wertarbyte/autorandr)
59 tree is unmaintained, with lots of open pull requests and issues. I forked it
60 and merged what I thought were the most important changes. If you are searching
61 for that version, see the [`legacy` branch](https://github.com/phillipberndt/autorandr/tree/legacy).
62 Note that the Python version is better suited for non-standard configurations,
63 like if you use `--transform` or `--reflect`. If you use `auto-disper`, you
64 have to use the bash version, as there is no disper support in the Python
65 version (yet). Both versions use a compatible configuration file format, so
66 you can, to some extent, switch between them.  I will maintain the `legacy`
67 branch until @wertarbyte finds the time to maintain his branch again.
68
69 If you are interested in why there are two versions around, see
70 [#7](https://github.com/phillipberndt/autorandr/issues/7),
71 [#8](https://github.com/phillipberndt/autorandr/issues/8) and
72 especially
73 [#12](https://github.com/phillipberndt/autorandr/issues/12)
74 if you are unhappy with this version and would like to contribute to the bash
75 version.
76
77 ## License information and authors
78
79 autorandr is available under the terms of the GNU General Public License
80 (version 3).
81
82 Contributors to this version of autorandr are:
83
84 * Adrián López
85 * andersonjacob
86 * Alexander Wirt
87 * Brice Waegeneire
88 * Chris Dunder
89 * Christoph Gysin
90 * Christophe-Marie Duquesne
91 * Daniel Hahler
92 * Maciej Sitarz
93 * Mathias Svensson
94 * Matthew R Johnson
95 * Nazar Mokrynskyi
96 * Phillip Berndt
97 * Rasmus Wriedt Larsen
98 * Simon Wydooghe
99 * Stefan Tomanek
100 * stormc
101 * tachylatus
102 * Timo Bingmann
103 * Timo Kaufmann
104 * Tomasz Bogdal
105 * Victor Häggqvist
106 * Jan-Oliver Kaiser
107
108 ## Installation/removal
109
110 You can use the `autorandr.py` script as a stand-alone binary. If you'd like to
111 install it as a system-wide application, there is a Makefile included that also
112 places some configuration files in appropriate directories such that autorandr
113 is invoked automatically when a monitor is connected or removed, the system
114 wakes up from suspend, or a user logs into an X11 session. Run `make install`
115 as root to install it.
116
117 If you prefer to have a system wide install managed by your package manager,
118 you can
119
120 * Use the [official Arch package](https://www.archlinux.org/packages/community/any/autorandr/).
121 * Use the [official Debian package](https://packages.debian.org/sid/x11/autorandr) on sid
122 * Use the [ebuild from zugaina](https://gpo.zugaina.org/x11-misc/autorandr) on Gentoo.
123 * Use the
124   [nix package](https://github.com/NixOS/nixpkgs/blob/master/nixos/modules/services/misc/autorandr.nix)
125   on NixOS.
126 * Use the automated nightlies generated by the
127   [openSUSE build service](https://build.opensuse.org/package/show/home:phillipberndt/autorandr)
128   for various distributions (RPM and DEB based).
129 * Use the [X binary package system](https://wiki.voidlinux.eu/XBPS)' on Void Linux 
130 * Build a .deb-file from the source tree using `make deb`.
131 * Build a .rpm-file from the source tree using `make rpm`.
132
133 We appreciate packaging scripts for other distributions, please file a pull
134 request if you write one.
135
136 If you prefer `pip` over your package manager, you can install autorandr with:
137
138     sudo pip install "git+http://github.com/phillipberndt/autorandr#egg=autorandr"
139
140 or simply
141
142     sudo pip install autorandr
143
144 if you prefer to use a stable version.
145
146 ## How to use
147
148 Save your current display configuration and setup with:
149
150     autorandr --save mobile
151
152 Connect an additional display, configure your setup and save it:
153
154     autorandr --save docked
155
156 Now autorandr can detect which hardware setup is active:
157
158     $ autorandr
159       mobile
160       docked (detected)
161
162 To automatically reload your setup:
163
164     $ autorandr --change
165
166 To manually load a profile:
167
168     $ autorandr --load <profile>
169
170 or simply:
171
172     $ autorandr <profile>
173
174 autorandr tries to avoid reloading an identical configuration. To force the
175 (re)configuration:
176
177     $ autorandr --load <profile> --force
178
179 To prevent a profile from being loaded, place a script call _block_ in its
180 directory. The script is evaluated before the screen setup is inspected, and
181 in case of it returning a value of 0 the profile is skipped. This can be used
182 to query the status of a docking station you are about to leave.
183
184 If no suitable profile can be identified, the current configuration is kept.
185 To change this behaviour and switch to a fallback configuration, specify
186 `--default <profile>`. The system-wide installation of autorandr by default
187 calls autorandr with a parameter `--default default`. There are three special,
188 virtual configurations called `horizontal`, `vertical` and `common`. They
189 automatically generate a configuration that incorporates all screens
190 connected to the computer. You can symlink `default` to one of these
191 names in your configuration directory to have autorandr use any of them
192 as the default configuration without you having to change the system-wide
193 configuration.
194
195 You can store default values for any option in an INI-file in
196 `~/.config/autorandr/settings.ini` in a section `config`. The most useful
197 candidate for doing that is `skip-options`, if you need it.
198
199 ## Advanced usage
200
201 ### Hook scripts
202
203 Three more scripts can be placed in the configuration directory
204 (as defined by the [XDG spec](https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html),
205 usually `~/.config/autorandr` or `~/.autorandr` if you have an old installation
206 for user configuration and `/etc/xdg/autorandr` for system wide configuration):
207
208 - `postswitch` is executed *after* a mode switch has taken place. This can be
209   used to notify window managers or other applications about the switch.
210 - `preswitch` is executed *before* a mode switch takes place.
211 - `postsave` is executed after a profile was stored or altered.
212 - `predetect` is executed before autorandr attempts to run xrandr. 
213
214 These scripts must be executable and can be placed directly in the configuration
215 directory, where they will always be executed, or in the profile subdirectories,
216 where they will only be executed on changes regarding that specific profile.
217
218 Instead (or in addition) to these scripts, you can also place as many executable
219 files as you like in subdirectories called `script_name.d` (e.g. `postswitch.d`).
220
221 If a script with the same name occurs multiple times, user configuration
222 takes precedence over system configuration (as specified by the
223 [XDG spec](https://specifications.freedesktop.org/basedir-spec/basedir-spec-latest.html))
224 and profile configuration over general configuration.
225
226 As a concrete example, suppose you have the files
227
228 - `/etc/xdg/autorandr/postswitch`
229 - `~/.config/autorandr/postswitch`
230 - `~/.config/autorandr/postswitch.d/notify-herbstluftwm`
231 - `~/.config/autorandr/docked/postswitch`
232
233 and switch from `mobile` to `docked`. Then
234 `~/.config/autorandr/docked/postswitch` is executed, since the profile specific
235 configuration takes precedence, and
236 `~/.config/autorandr/postswitch.d/notify-herbstluftwm` is executed, since
237 it has a unique name.
238
239 If you switch back from `docked` to `mobile`, `~/.config/autorandr/postswitch`
240 is executed instead of the `docked` specific `postswitch`.
241
242 In these scripts, some of autorandr's state is exposed as environment variables
243 prefixed with `AUTORANDR_`, such as:
244 - `AUTORANDR_CURRENT_PROFILE`
245 - `AUTORANDR_CURRENT_PROFILES`
246 - `AUTORANDR_PROFILE_FOLDER`
247 - `AUTORANDR_MONITORS`
248
249 If you experience issues with xrandr being executed too early after connecting
250 a new monitor, then you can use a `predetect` script to delay the execution.
251 Write e.g. `sleep 1` into that file to make autorandr wait a second before
252 running `xrandr`.
253
254 ### Wildcard EDID matching
255
256 The EDID strings in the `~/.config/autorandr/*/setup` files may contain an
257 asterisk to enable wildcard matching: Such EDIDs are matched against connected
258 monitors using the usual file name globbing rules. This can be used to create
259 profiles matching multiple (or any) monitors.
260
261 ## Changelog
262
263 **autorandr 1.10.1**
264 * *2020-05-04* Revert making the launcher the default (fixes #195)
265
266 **autorandr 1.10**
267 * *2020-04-23* Fix hook script execution order to match description from readme
268 * *2020-04-11* Handle negative gamma values (fixes #188)
269 * *2020-04-11* Sort approximate matches in detected profiles by quality of match
270 * *2020-01-31* Handle non-ASCII environment variables (fixes #180)
271 * *2019-12-31* Fix output positioning if the top-left output is not the first
272 * *2019-12-31* Accept negative gamma values (and interpret them as 0)
273 * *2019-12-31* Prefer the X11 launcher over systemd/udev configuration
274
275 **autorandr 1.9**
276
277 * *2019-11-10* Count closed lids as disconnected outputs
278 * *2019-10-05* Do not overwrite existing configurations without `--force`
279 * *2019-08-16* Accept modes that don't match the WWWxHHH pattern
280 * *2019-03-22* Improve bash autocompletion
281 * *2019-03-21* Store CRTC values in configurations
282 * *2019-03-24* Fix handling of recently disconnected outputs (See #128 and #143)
283
284 **autorandr 1.8.1**
285
286 * *2019-03-18* Removed mandb call from Makefile
287
288 **autorandr 1.8**
289
290 * *2019-02-17* Add an X11 daemon that runs autorandr when a display connects (by @rliou92, #127)
291 * *2019-02-17* Replace width=0 check with disconnected to detect disconnected monitors (by @joseph-jones, #139)
292 * *2019-02-17* Fix handling of empty padding (by @jschwab, #138)
293 * *2019-02-17* Add a man page (by @somers-all-the-time, #133)
294
295 **autorandr 1.7**
296
297 * *2018-09-25* Fix FB size computation with rotated screens (by @Janno, #117)
298
299 **autorandr 1.6**
300
301 * *2018-04-19* Bugfix: Do not load default profile unless --change is set
302 * *2018-04-30* Added a `AUTORANDR_MONITORS` variable to hooks (by @bricewge, #106)
303 * *2018-06-29* Fix detection of current configuration if extra monitors are active
304 * *2018-07-11* Bugfix in the latest change: Correctly handle "off" minitors when comparing
305 * *2018-07-19* Do not kill spawned user processes from systemd unit
306 * *2018-07-20* Correctly handle "off" monitors when comparing -- fixup for another bug.
307
308 **autorandr 1.5**
309
310 * *2018-01-03* Add --version
311 * *2018-01-04* Fixed vertical/horizontal/clone-largest virtual profiles
312 * *2018-03-07* Output all non-error messages to stdout instead of stderr
313 * *2018-03-25* Add --detected and --current to filter the profile list output
314 * *2018-03-25* Allow wildcard matching in EDIDs
315
316 **autorandr 1.4**
317
318 * *2017-12-22* Fixed broken virtual profile support
319 * *2017-12-14* Added support for a settings file
320 * *2017-12-14* Added a virtual profile `off`, which disables all screens
321
322 **autorandr 1.3**
323
324 * *2017-11-13* Add a short form for `--load`
325 * *2017-11-21* Fix environment stealing in `--batch` mode (See #87)
326
327 **autorandr 1.2**
328
329 * *2017-07-16* Skip `--panning` unless it is required (See #72)
330 * *2017-10-13* Add `clone-largest` virtual profile
331
332 **autorandr 1.1**
333
334 * *2017-06-07* Call systemctl with `--no-block` from udev rule (See #61)
335 * *2017-01-20* New script hook, `predetect`
336 * *2017-01-18* Accept comments (lines starting with `#`) in config/setup files
337
338 **autorandr 1.0**
339
340 * *2016-12-07* Tag the current code as version 1.0.0; see github issue #54
341 * *2016-10-03* Install a desktop file to `/etc/xdg/autostart` by default
342
343 %package zsh-completion
344 Summary: zsh-completion for autorandr
345 Requires: zsh
346 Requires: %{name}
347 %description zsh-completion
348 This package provides zsh-completion files for autorandr
349
350 %prep
351 %setup -n %{name}-%{version} -n %{name}-%{version}
352 %if %{py_ver} == 3
353 pathfix.py -pni "%{__python3} %{py3_shbang_opts}" ./autorandr.py
354 %else
355 pathfix.py -pni "%{__python2} %{py2_shbang_opts}" ./autorandr.py
356 %endif
357
358 %install
359 make DESTDIR="%{buildroot}" PREFIX=/usr install
360 install -vDm 644 README.md -t "%{buildroot}/usr/share/doc/%{name}/"
361 install -vDm 644 contrib/zsh_completion/_autorandr -t %{buildroot}%{_datarootdir}/zsh/site-functions/
362
363
364 %files
365 %defattr(-,root,root,-)
366 %attr(0644,root,root) %{_unitdir}/autorandr.service
367 %license gpl-3.0.txt 
368 %doc README.md
369 %config(noreplace) %{_sysconfdir}/*
370 %{_bindir}/*
371 %{_mandir}
372 %{_datarootdir}/bash-completion/completions/autorandr
373 %{_udevrulesdir}/40-monitor-hotplug.rules
374
375 %files zsh-completion
376 %{_datarootdir}/zsh/site-functions/_autorandr
377
378 %changelog
379 * Mon Jun 08 2020 Jerzy Drozdz <jerzy.drozdz@jdsieci.pl> - 1.10.1-1
380 - Updated to stable 1.10.1
381 - Added zsh-completion subpackage
382 * Wed May 22 2019 Maciej Sitarz <macieksitarz@wp.pl> - 1.8.1-1
383 - Updated to stable 1.8.1
384 * Fri Sep 28 2018 Maciej Sitarz <macieksitarz@wp.pl> - 1.7-1
385 - Updated to stable 1.7
386 * Thu Jul 19 2018 Maciej Sitarz <macieksitarz@wp.pl> - 1.5-1
387 - Updated to stable 1.5
388 - Changed dest path for systemd service file
389 * Sun Oct 01 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 1.1-2
390 - Added conditionals for pm-utils, compability with Fedora26+
391 - Removed bash-completion from requisites
392 - Removed udev from requisites
393 * Sun Sep 03 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 1.1-1
394 - Update to stable 1.1
395 * Fri Feb 17 2017 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20170217git-1
396 - Update to master
397 * Wed Jul 6 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160706git-1
398 - Set default value of $XDG_CONFIG_DIRS to fulfill the standard
399 * Fri Jul 1 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160701git-1.1
400 - fixed running udevadm in post
401 * Fri Jul 1 2016 Jerzy Drozdz <rpmbuilder@jdsieci.pl> - 20160701git-1
402 - initial build