]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Debhelper 10 automatically builds --with systemd
[unscd.git] / debian / rules
index e5e2a42358b9aec4a26b346c8a2a7f4828642e63..c29b81548401c68ed879f07e4dc064bcb7862a21 100755 (executable)
@@ -1,14 +1,16 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
-       dh $@ --with systemd
+       dh $@
 
 override_dh_auto_clean:
        rm -f nscd
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
+       gcc $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \