]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Debhelper 10 automatically builds --with systemd
[unscd.git] / debian / rules
index e0ec0238673b5fa85c044c650b022e8645779349..c29b81548401c68ed879f07e4dc064bcb7862a21 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
        dh $@
 
@@ -8,7 +10,7 @@ override_dh_auto_clean:
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \
@@ -20,3 +22,6 @@ override_dh_auto_install:
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade