]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Debhelper 10 automatically builds --with systemd
[unscd.git] / debian / rules
index b93568908ee54cf7404cd48c5396f9a745679fee..c29b81548401c68ed879f07e4dc064bcb7862a21 100755 (executable)
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
 %:
        dh $@
 
@@ -8,10 +10,18 @@ override_dh_auto_clean:
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       gcc $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
+       help2man --name 'nscd which does not hang' \
+               --include debian/help2man \
+               --no-info \
+               ./nscd > debian/unscd.man
+       ln -fs unscd.man debian/nscd.man
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/
        install -t debian/unscd/usr/sbin/ nscd
        install -d debian/unscd/etc/
        install -m644 -t debian/unscd/etc/ debian/nscd.conf
+
+override_dh_systemd_start:
+       dh_systemd_start --restart-after-upgrade --no-stop-on-upgrade