]> git.donarmstrong.com Git - lilypond.git/blobdiff - flower/test/Makefile.am
release: 0.1.52
[lilypond.git] / flower / test / Makefile.am
index 1aa34af3872d2ae126d3e63a4ade362d3a8f593c..c9521304263a309ddf4df13da6d1932498c843f0 100644 (file)
@@ -11,6 +11,9 @@
 #      Han-Wen Nienhuys <hanwen@stack.nl>
 #
 
+# the wild-perl script needs this.
+real_topdir = $(top_srcdir)/..
+
 # bin_PROGRAMS = test
 
 # TEST = test
@@ -27,4 +30,4 @@ noinst_HEADERS = flower-test.hh
 INCLUDES = -I../include
 
 $(srcdir)/Makefile.am: $(srcdir)/Makefile.am.wild
-       $(PERL) $(top_srcdir)/bin/wild-perl < $< > $@
\ No newline at end of file
+       $(PERL) $(top_srcdir)/bin/wild-perl --top-srcdir="$(real_topdir)" < $< > $@
\ No newline at end of file