]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
add configure ac patch
[lilypond.git] / debian / rules
index bf8c1b240e3fefe0ee3571d0937bebfd3942304f..0b50368e6dcd8b1ac850df771f83714ec22872ab 100755 (executable)
@@ -5,11 +5,9 @@
 # version 2 or later for copying conditions.  There is NO warranty.
 #
 
-export MAILADDRESS = lilypond@packages.debian.org
+include VERSION
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
+export MAILADDRESS = lilypond@packages.debian.org
 
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
@@ -32,8 +30,7 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
 endif
 
 %:
-       dh $@ --parallel --with autotools-dev --with python2 --with quilt
-
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt --with autoreconf
 
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically
@@ -50,6 +47,9 @@ override_dh_auto_install-indep:
        $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
        rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
+       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
 ## info documentation (missing images) if we call their makefile
@@ -90,8 +90,8 @@ override_dh_install:
        dh_install --list-missing
 
 override_dh_python2:
-       dh_python2
-       dh_python2 usr/share/lilypond/*/python/
+       dh_python2 --verbose
+       dh_python2 --verbose usr/share/lilypond/$(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)/python/
 
 override_dh_compress:
        dh_compress -X.ly
@@ -104,6 +104,12 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done;
 
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
+
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
 ## the Debian package and should not need to be regenerated or