]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
add configure ac patch
[lilypond.git] / debian / rules
index 7e59b1e63a1441dd9c9716a6e9580bd88dafb510..0b50368e6dcd8b1ac850df771f83714ec22872ab 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -34,7 +30,7 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
 endif
 
 %:
-       dh $@ --parallel --with autotools-dev --with python2 --with quilt
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt --with autoreconf
 
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically