]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
add configure ac patch
[lilypond.git] / debian / rules
index 7c652908cf1c9106369d08d9f6cf84d52b0d336b..0b50368e6dcd8b1ac850df771f83714ec22872ab 100755 (executable)
@@ -9,10 +9,6 @@ include VERSION
 
 export MAILADDRESS = lilypond@packages.debian.org
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
-
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
 CXXFLAGS := $(shell dpkg-buildflags --get CXXFLAGS)
@@ -34,8 +30,7 @@ ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
 endif
 
 %:
-       dh $@ --parallel --with autotools-dev --with python2 --with quilt
-
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt --with autoreconf
 
 ## we need to nuke the parser files, because if there is a mistmatch
 ## between upstreams bison and our bison, the build will fail epically
@@ -52,6 +47,8 @@ override_dh_auto_install-indep:
        $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
        rm -rf $(CURDIR)/debian/tmp/usr/share/omf
        rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
        perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
 
 ## Unfortunately, lilypond is kind of broken, and installs the wrong
@@ -107,6 +104,12 @@ override_dh_installdocs:
                install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
        done;
 
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
+
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
 ## the Debian package and should not need to be regenerated or