]> git.donarmstrong.com Git - lilypond.git/blobdiff - debian/rules
add configure ac patch
[lilypond.git] / debian / rules
index 2370983443fa568598a30ce12f50dc5333f45365..0b50368e6dcd8b1ac850df771f83714ec22872ab 100755 (executable)
@@ -5,11 +5,9 @@
 # version 2 or later for copying conditions.  There is NO warranty.
 #
 
-export MAILADDRESS = lilypond@packages.debian.org
+include VERSION
 
-# fontconfig blows chunks if it can't write to $HOME; and some
-# buildds set it to a bogus value.
-export HOME = /tmp
+export MAILADDRESS = lilypond@packages.debian.org
 
 DEB_HOST_ARCH ?= $(shell dpkg-architecture -qDEB_HOST_ARCH)
 CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
@@ -18,46 +16,99 @@ ifneq (,$(filter $(DEB_HOST_ARCH), i386 kfreebsd-i386))
   config_opt = --disable-optimising
   CFLAGS := $(filter-out -O%, $(CFLAGS))
   CXXFLAGS := $(filter-out -O%, $(CXXFLAGS))
+else
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),noopt))
+  config_opt = --disable-optimising
 else
   config_opt = --enable-optimising
 endif
+endif
 
 DOC_OPTIONS := WEB_TARGETS="offline"
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-       DOC_OPTIONS := $(DOC_OPTIONS) $(DEB_BUILD_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
+       DOC_OPTIONS := $(DOC_OPTIONS) CPU_COUNT=$(firstword $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
 endif
 
 %:
-       dh $@ --parallel --with-autotools-dev --with-python2 --list-missing
-
+       dh $@ --parallel --with autotools-dev --with python2 --with quilt --with autoreconf
 
-override_dh_auto_configure: 
+## we need to nuke the parser files, because if there is a mistmatch
+## between upstreams bison and our bison, the build will fail epically
+override_dh_auto_configure:
+       rm -f lily/out/parser.*
        dh_auto_configure -- --disable-checking --enable-debugging $(config_opt)
 
 override_dh_auto_build-indep:
        dh_auto_build
-       $(MAKE) $(DOC_OPTIONS) doc
+       $(MAKE) doc $(DOC_OPTIONS)
 
 override_dh_auto_install-indep:
-       $(MAKE) install-doc prefix=$(CURDIR)/debian/tmp/usr/
+       $(MAKE) install-doc $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/
+       $(MAKE) install-info $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr
+       rm -rf $(CURDIR)/debian/tmp/usr/share/omf
+       rm -rf $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/input
+       perl debian/move_info_images_from_html_doc $(CURDIR)/debian/tmp/usr/share/info/ $(CURDIR)/debian/tmp/usr/share/doc/lilypond/html/Documentation/
+       perl debian/symlink_html_images_to_info_images $(CURDIR)/debian/tmp/usr/share/info/lilypond
+       perl debian/remove_w3c_callback $(CURDIR)/debian/tmp/usr/share/doc/lilypond/ $(CURDIR)/debian/tmp/usr/share/info/
+
+## Unfortunately, lilypond is kind of broken, and installs the wrong
+## info documentation (missing images) if we call their makefile
+## directly. They also don't provide an install rule which doesn't
+## install the documentation, which we don't care about for the
+## architecture dependent build
+override_dh_auto_install-arch:
+       for dir in `echo */*makefile|xargs -n 1 dirname|grep -v Documentation`; do \
+               $(MAKE) --no-builtin-rules PACKAGE=LILYPOND package=lilypond -C $$dir install $(DOC_OPTIONS) prefix=$(CURDIR)/debian/tmp/usr/; \
+       done;
+
+## we need to nuke the parser files, because if there is a mistmatch
+## between upstreams bison and our bison, the build will fail epically
+override_dh_auto_clean:
+       rm -f lily/out/parser.*
+       dh_auto_clean
 
-## we need to install only the png, ly and english html files into the
-## doc-html package, and only the english pdfs into the doc-pdf
-## package. Because dh_install doesn't support regexes, we'll use find
-## to replace the contents of the .install file before we call
-## dh_install
+## we need to install only the png, jpg, css, ly and english html
+## files into the doc-html package, and only the english pdfs into the
+## doc-pdf package. Because dh_install doesn't support regexes, we'll
+## use find to replace the contents of the .install file before we
+## call dh_install
 override_dh_install:
-       echo -e 'usr/share/doc/lilypond/html/*/*/*.ly\nusr/share/doc/lilypond/html/*/*/*.png' \
+       /bin/echo -e 'usr/share/doc/lilypond/html/*/*/*.ly\nusr/share/doc/lilypond/html/*/*/*.png' \
                > $(CURDIR)/debian/lilypond-doc-html.install
+       /bin/echo -e 'usr/share/doc/lilypond/html/*/*/*.jpg\nusr/share/doc/lilypond/html/*/*/*.css' \
+               >> $(CURDIR)/debian/lilypond-doc-html.install
        find $(CURDIR)/debian/tmp/ -type f \
                -regex '.*usr/share/doc/lilypond/.*/[^\.]+.html' \
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-html.install
-       echo -e ''> $(CURDIR)/debian/lilypond-doc-pdf.install
+       /bin/echo -e ''> $(CURDIR)/debian/lilypond-doc-pdf.install
        find $(CURDIR)/debian/tmp/ -type f \
                -regex '.*usr/share/doc/lilypond/.*/[^\.]+.pdf' \
                -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
-       dh_install
+       find $(CURDIR)/debian/tmp/ -type f \
+               -regex '.*usr/share/doc/lilypond/.*/[^\.]+.preview.pdf' \
+               -printf '%P\n' >> $(CURDIR)/debian/lilypond-doc-pdf.install
+       dh_install --list-missing
+
+override_dh_python2:
+       dh_python2 --verbose
+       dh_python2 --verbose usr/share/lilypond/$(MAJOR_VERSION).$(MINOR_VERSION).$(PATCH_LEVEL)/python/
+
+override_dh_compress:
+       dh_compress -X.ly
 
+override_dh_installdocs:
+       dh_installdocs
+       for a in $(wildcard $(CURDIR)/debian/*.doc-base-special); do \
+               package=`basename $$a .doc-base-special`; \
+               install -d debian/$$package/usr/share/doc-base; \
+               install -m0644 $$a debian/$$package/usr/share/doc-base/$$package; \
+       done;
+
+override_dh_auto_test:
+ifneq (,$(filter $(DEB_BUILD_OPTIONS),nocheck))
+       $(MAKE) test-baseline
+    $(MAKE) test
+endif
 
 ## this rule will update debian/control and the per-language install
 ## files; all of the files it generates/modifies should be included in
@@ -65,65 +116,3 @@ override_dh_install:
 ## modified.
 update-doc-packages:
        perl debian/update_doc_packages
-
-
-## # Build architecture-independent files here.
-## binary-indep: DH_OPTIONS=-i
-## binary-indep: build-doc install
-##     dh_testdir
-##     dh_testroot
-##     # Install LilyPond web documentation...
-##     $(MAKE) install-doc prefix=$(CURDIR)/debian/lilypond-doc/usr/
-##     # it installs a random dir-dep file for no reason
-##     rm -f $(CURDIR)/debian/lilypond-doc/usr/share/info/*-dir-dep*
-## 
-##     dh_installinfo
-##     dh_installdocs
-##     # remove the useless offline-root directory
-##     mv $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root/* \
-##             $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/.;
-##     rmdir $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html/offline-root;
-##     find $(CURDIR)/debian/lilypond-doc/usr/share/doc/lilypond/html \
-##             -type d -empty -delete
-##     dh_installemacsen
-## 
-##     install -m 644 debian/xiao-haizi-guai-guai.ly debian/sakura-sakura.ly \
-##             $(r_data)/$(d)/examples
-##     dh_installchangelogs
-## 
-##     dh_link usr/share/lilypond/$(VERSION)/tex \
-##                     usr/share/texmf/tex/lilypond \
-##             usr/share/lilypond/$(VERSION)/fonts/source \
-##                     usr/share/texmf/fonts/source/public/lilypond \
-##             usr/share/lilypond/$(VERSION)/fonts/type1 \
-##                     usr/share/texmf/fonts/type1/public/lilypond \
-## 
-##     dh_pysupport /usr/share/lilypond/${VERSION}/python
-## 
-##     dh_compress -X$(d)/html/
-##     dh_fixperms
-##     dh_installdeb
-##     dh_gencontrol
-##     dh_md5sums
-##     dh_builddeb
-## 
-## binary-arch: DH_OPTIONS=-s
-## binary-arch: build install
-##     dh_testdir
-##     dh_testroot
-##     dh_installdocs AUTHORS.txt NEWS.txt README.txt \
-##             DEDICATION THANKS 
-## 
-## 
-##     dh_installemacsen
-##     dh_installchangelogs Documentation/misc/CHANGES* Documentation/misc/ChangeLog*
-## 
-##     dh_strip
-##     dh_pysupport /usr/share/lilypond/${VERSION}/python
-##     dh_compress
-##     dh_fixperms
-##     dh_installdeb
-##     dh_shlibdeps
-##     dh_gencontrol
-##     dh_md5sums
-##     dh_builddeb