]> git.donarmstrong.com Git - debbugs.git/blobdiff - .travis.yml
Fix default user for usertags
[debbugs.git] / .travis.yml
index 9bd77e628a83273a8c569681c40e188a1138e3d8..b6f1be88d0699534d8be5e2e7b4c4fb77a657fca 100644 (file)
@@ -1,14 +1,14 @@
+dist: trusty
+sudo: required
 before_install:
   - sudo apt-get -qq update
-  - >
-    sudo apt-get install -y libparams-validate-perl
-    libmailtools-perl libmime-tools-perl libio-stringy-perl
-    libmldbm-perl liburi-perl libsoap-lite-perl libcgi-simple-perl
-    libhttp-server-simple-perl libtest-www-mechanize-perl
-    libmail-rfc822-address-perl libsafe-hole-perl libuser-perl
-    libconfig-simple-perl libtest-pod-perl
-    liblist-moreutils-perl libtext-template-perl graphviz
-language: perl
+  - sudo apt-get install -y devscripts equivs
+  - dch -r -m ''
+  - mk-build-deps -s sudo -i debian/control
 script:
-  - make
-  - make test
+  - make; make test
+notifications:
+  irc:
+    channels:
+      - "irc.oftc.net#debbugs"
+  email: false