]> git.donarmstrong.com Git - debbugs.git/blobdiff - .travis.yml
Fix default user for usertags
[debbugs.git] / .travis.yml
index 307b8ed118169ed62f8565b6dfd867bb0831dff0..b6f1be88d0699534d8be5e2e7b4c4fb77a657fca 100644 (file)
@@ -1,16 +1,12 @@
+dist: trusty
+sudo: required
 before_install:
   - sudo apt-get -qq update
-  - >
-    sudo apt-get install -y libparams-validate-perl
-    libmailtools-perl libmime-tools-perl libio-stringy-perl
-    libmldbm-perl liburi-perl libsoap-lite-perl libcgi-simple-perl
-    libhttp-server-simple-perl libtest-www-mechanize-perl
-    libmail-rfc822-address-perl libsafe-hole-perl libuser-perl
-    libconfig-simple-perl libtest-pod-perl
-    liblist-moreutils-perl libtext-template-perl graphviz
-    libfile-libmagic-perl libgravatar-url-perl libwww-perl imagemagick
+  - sudo apt-get install -y devscripts equivs
+  - dch -r -m ''
+  - mk-build-deps -s sudo -i debian/control
 script:
-  - make
+  - make; make test
 notifications:
   irc:
     channels: