]> git.donarmstrong.com Git - neurodebian.git/commitdiff
More work on the VM.
authorMichael Hanke <michael.hanke@gmail.com>
Sun, 10 Oct 2010 00:56:12 +0000 (20:56 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Sun, 10 Oct 2010 00:56:12 +0000 (20:56 -0400)
debian/changelog
debian/control
etc/gconf/20_neurodebian-panel-default-setup.entries
tools/nd_compactvdi
tools/nd_setupguestos

index 50543320562a7bc301cd9321f06bed5874204cc6..ff699d68cbed1d7acd4acd16e1a4f03c43208852 100644 (file)
@@ -1,4 +1,4 @@
-neurodebian (1.0) unstable; urgency=low
+neurodebian (1.0) squeeze; urgency=low
 
   * Initial release.
 
index db9519d3f4df02bfee58ccc3a1879d26e31f3f61..dc6434f8e8577f08b635580d6c104d038060507e 100644 (file)
@@ -30,7 +30,7 @@ Description: NeuroDebian development tools
 
 Package: neurodebian-desktop
 Architecture: all
-Depends: ${misc:Depends}, ssh-askpass-gnome | ssh-askpass
+Depends: ${misc:Depends}, ssh-askpass-gnome | ssh-askpass, desktop-base, gnome-icon-themes
 Suggests:
 Description: neuroscience research environment
  Pacifier
@@ -46,7 +46,7 @@ Description: neuroscience research environment
 
 Package: neurodebian-guest-additions
 Architecture: all
-Depends: ${misc:Depends}, sudo, virtualbox-ose-guest-utils, virtualbox-ose-guest-x11, virtualbox-ose-guest-dkms, neurodebian-desktop
+Depends: ${misc:Depends}, sudo, virtualbox-ose-guest-utils, virtualbox-ose-guest-x11, virtualbox-ose-guest-dkms, neurodebian-desktop, gdm
 Recommends: chromium-browser
 Suggests:
 Description: add-ons and configuration for the NeuroDebian virtual machine
index 0548a70fe96c9db1fbe1953ad3de04c23dea947f..b5b90f35439e78b178b9412d0f2e7e2f9580cdb4 100644 (file)
             <value>
               <string>applet_0</string>
             </value>
-            <value>
-              <string>applet_1</string>
-            </value>
         </list>
       </value>
     </entry>
index 5f2c544f90e29c042e968ad7a64a4b2657d4ee6b..0c0c8ab6e1486406c2faf94001d498cb971a3eca 100755 (executable)
@@ -40,7 +40,7 @@ find vbmnt/var/lib/apt -type f -name '*debian*' -o -type f -name '*list*' -delet
 # user data
 rm -f vbmnt/root/.*history
 # everything for the default user
-find vbmnt/home/brain -mindepth 1 -delete
+#find vbmnt/home/brain -mindepth 1 -delete
 
 # unmount filesystem
 umount vbmnt
index 533feedf2c8af0bf6372e008892f1902ecc2febe..e2b5529e156965874a04a93b91a4e91f50568deb 100644 (file)
@@ -1,8 +1,14 @@
 #!/bin/bash
 
+# play safe
+set -e
+set -u
+
 # Standard Debian install
 
-# maybe have dedicated hard-drives for swap and home
+# prepare on hydra and use debproxy for speed
+
+# have dedicated hard-drives for swap and home
 
 # hostname: neurodebian
 # domain: ''
@@ -20,7 +26,9 @@
 # All files in one partition/
 # just base system, run selection, but no tasks (not even 'Standard system')
 
-apt-get etckeeper
+# set root password to 'neurodebian' too
+
+apt-get install etckeeper
 
 # setup etckeeper
 git config --global user.name NeuroDebian
@@ -33,18 +41,18 @@ git config --global user.email nd@localhost
 wget -O /etc/apt/sources.list.d/neuro.debian.net.list http://neuro.debian.net/_static/neurodebian.squeeze.us.sources.list
 wget -O - http://neuro.debian.net/_static/neuro.debian.net.asc | apt-key add -
 
-echo "deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free" >> /etc/apt/sources.list.d/backports.debian.org.list
-cat << EOT >> /etc/apt/preferences.d/backports.debian.org
+echo "deb http://backports.debian.org/debian-backports squeeze-backports main contrib non-free" > /etc/apt/sources.list.d/backports.debian.org.list
+cat << EOT > /etc/apt/preferences.d/backports.debian.org.pref
 Package: *
 Pin: release a=squeeze-backports
 Pin-Priority: 200
 EOT
 
-apt-get install neurodebian-guest-additions
-
-apt-get install --no-install-recommends \
- desktop-base gdm gnome-core mc evince bash-completion ntpdate \
- file-roller gnome-keyring gksu gnome-utils gnome-themes eog
+apt-get update
+apt-get install --no-install-recommends neurodebian-guest-additions \
+ gnome-core mc evince bash-completion ntpdate file-roller gnome-utils
+ gnome-themes eog vim
+ software-center gdebi update-notifier gedit-plugins gnome-media synaptic menu less
 
 # intermediate cleanup to prevent virtual harddrive from fragmenting too much
 find /var/cache/apt/archives/ -name '*.deb' -delete
@@ -52,7 +60,6 @@ find /var/cache/apt/archives/ -name '*.deb' -delete
 # cleanup unwanted stuff
 # video drivers (all but vesa)
 apt-get purge $(apt-cache search --names-only --installed xserver-xorg-video | grep xserver-xorg-video | cut -d ' ' -f 1,1) xserver-xorg-video-vesa+
-apt-get purge gnome-media
 
 # and whatever is obsolete
 apt-get autoremove --purge
@@ -64,3 +71,6 @@ apt-get autoremove --purge
 # next step purge network interface config to give the power to network manager
 # important
 #adduser brain netdev
+
+apt-get install flashplugin-nonfree sun-java6-plugin
+