]> git.donarmstrong.com Git - neurodebian.git/commitdiff
Fixes.
authorMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:52:54 +0000 (16:52 -0400)
committerMichael Hanke <michael.hanke@gmail.com>
Wed, 3 Nov 2010 20:53:25 +0000 (16:53 -0400)
debian/changelog
etc/xdg/autostart/vmsetupwizard.desktop
tools/nd-vmsetupwizard
tools/nd_setupguestos

index 4fc8522a635ecfaa7aa854ac381b0e0d41eac27e..3115cc7e4c4d2896a9dd29266f468ff92a4eb39a 100644 (file)
@@ -1,5 +1,5 @@
-neurodebian (0.9) squeeze; urgency=low
+neurodebian (0.10) squeeze; urgency=low
 
   * Initial release.
 
- -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 16:36:24 -0400
+ -- Michael Hanke <michael.hanke@gmail.com>  Wed, 03 Nov 2010 16:53:06 -0400
index c6ccdd505b4c409269a00ac842f62efb4197c97d..6cad50db435f4cfeebb79480a5b8a8b9aa9959eb 100644 (file)
@@ -1,6 +1,6 @@
 [Desktop Entry]
 Name=NeuroDebian VirtualMachine setup wizard
 Comment=Runs once to perform final configuration steps
-Exec=[ ! -e /etc/neurodebian/guest/setupwizard_done ] && nd-vmsetupwizard
+Exec=bash -c "[ ! -e /etc/neurodebian/guest/setupwizard_done ] && nd-vmsetupwizard"
 Terminal=false
 Type=Application
index ca91553caa7dc741c01f304874818efe7d393eb3..d9f4046a6cb6682639b956ee4b48c54ca188ef71 100755 (executable)
@@ -21,33 +21,6 @@ zenity --info $icon_opt --title="NeuroDebian Setup Wizard" \
        --text="Welcome to the NeuroDebian virtual machine!
 
 This is the first time you have started this virtual machine. We will now perform a few simple steps to finalize its configuration. This includes upgrading the system to the latest available versions and installing additional software packages upon your request."
-
-# install custom filter for synaptics
-sudo mkdir -p /root/.synaptic
-sudo cat << EOT >> /root/.synaptic/filters
-filter "NeuroDebian" {
-  section {
-    inclusive false;
-    sections {
-    };
-  };
-  status {
-    flags 0x1ffff;
-  };
-  pattern {
-    andMode 0;
-    patterns {
-      Origin; "neuro.debian.net"; false;
-      Maintainer; "team@neuro.debian.net"; false;
-    };
-  };
-  priority {
-  };
-  reducedview {
-    enabled false;
-  };
-};
-EOT
 fi
 
 if ! zenity --question $icon_opt --title="NeuroDebian Setup Wizard" \
@@ -72,8 +45,35 @@ if [ ! -e /etc/popularity-contest.conf ]; then
        nd-autoinstall popularity-contest /etc/popularity-contest.conf || true
 fi
 
-# essential things are done -- let's mark sucess
+# install custom filter for synaptics
 if [ $first_run -eq 1 ]; then
+       sudo mkdir -p /root/.synaptic
+       sudo bash -c 'cat << EOT >> /root/.synaptic/filters
+filter "NeuroDebian" {
+  section {
+    inclusive false;
+    sections {
+    };
+  };
+  status {
+    flags 0x1ffff;
+  };
+  pattern {
+    andMode 0;
+    patterns {
+      Origin; "neuro.debian.net"; false;
+      Maintainer; "team@neuro.debian.net"; false;
+    };
+  };
+  priority {
+  };
+  reducedview {
+    enabled false;
+  };
+};
+EOT
+'
+       # essential things are done -- let's mark sucess
        sudo bash -c "mkdir -p $cfg_dir && touch $success_flag"
 fi
 
index 14aa5c0b2a86a4fe884e172357ffd41933fe8845..0c8c8ee397a2d335c95636fb201403513d0dff30 100644 (file)
@@ -73,17 +73,6 @@ apt-get purge $(apt-cache search --names-only --installed xserver-xorg-video | g
 # and whatever is obsolete
 apt-get autoremove --purge
 
-# install network manager applet
-# but we don't want to have all the openvpn stuff that pull in an armada of
-# things: I did it by hand in aptitude
-
-# next step purge network interface config to give the power to network manager
-# important
-#adduser brain netdev
-
-#apt-get install flashplugin-nonfree sun-java6-plugin
-
-
 # custom config
 # use NeuroDebian website as default homepage
 sed -i -e 's,http://www.debian.org,http://neuro.debian.net,g' /etc/chromium-browser/master_preferences