]> git.donarmstrong.com Git - debbugs.git/blobdiff - debian/rules
use uri_escape_utf8 instead of uri_escape
[debbugs.git] / debian / rules
index 0929fc3f7d4c821cb34f7038cdd4ed2871fac37e..7bdd341f7ab2e7ce59ca12837a2c5e56aedfa278 100755 (executable)
@@ -6,16 +6,43 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-tmp_dir                := $(CURDIR)/debian/tmp
+DEST_DIR := $(CURDIR)/debian/tmp
+PERL ?= /usr/bin/perl
 
-build:
-# There is nothing to build here, so this rule can be left empty.
+
+build: build-arch build-indep
+
+build-arch:
+# nothing to do, as there aren't any architecture-dependent packages
+
+build-indep: build-stamp
+
+build-stamp:
+# Call the test suite
+       $(PERL) Makefile.PL INSTALLDIRS=vendor
+       $(MAKE) -f Makefile.perl
+       $(MAKE) test
+       touch $@
 
 clean:
        dh_testdir
        dh_testroot
+       rm -f *-stamp;
+       if [ -e Makefile.perl ]; then  \
+               $(MAKE) -f Makefile.perl clean; \
+       fi;
        #something to remove all trace and *.trace files?
-       dh_clean build-stamp
+       rm -f debbugs.trace Makefile.perl.old
+       dh_clean
+
+install: install-stamp
+install-stamp: build
+       dh_testroot
+       dh_clean -k
+       dh_installdirs
+       $(MAKE) install_mostfiles DESTDIR=$(DEST_DIR)
+       $(MAKE) -f Makefile.perl install DESTDIR=$(DEST_DIR)
+       touch $@
 
 binary-arch:
 # nothing to do, as there aren't any architecture-dependent packages
@@ -25,18 +52,22 @@ binary-indep: build install
        dh_testroot
        dh_clean -k
        dh_installdirs
-       $(MAKE) install_mostfiles DESTDIR=$(tmp_dir)
+       $(MAKE) install_mostfiles DESTDIR=$(DEST_DIR)
+       $(MAKE) -f Makefile.perl install DESTDIR=$(DEST_DIR)
+       dh_install --sourcedir=debian/tmp --fail-missing
        dh_installdocs
        dh_installchangelogs
        dh_strip
-       dh_compress -X examples/text
        dh_fixperms
        #chown bugs.bugs $(var_dir)/spool/incoming
        dh_installdeb
+       dh_perl
+       dh_compress -X examples/text
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
+
 binary: binary-indep binary-arch
 .PHONY: build clean install binary-indep binary-arch binary