]> git.donarmstrong.com Git - roundcube.git/blobdiff - debian/rules
Rework how symlinks work. The only directory to use is
[roundcube.git] / debian / rules
index 529c41f71a79e8c012560ba76b7d414251984702..49ef123b5624e3fd7fa87998910e8a2f7ff44775 100755 (executable)
@@ -4,22 +4,7 @@ include /usr/share/cdbs/1/rules/debhelper.mk
 
 DEB_INSTALL_CHANGELOGS_ALL=CHANGELOG
 
-# In order to regenerate 'debian/control' :
-#    DEB_AUTO_UPDATE_DEBIAN_CONTROL=yes fakeroot debian/rules clean
-# Then check manually if everything's ok
-
 binary-install/roundcube-core::
-       # Remove plugins
-       rm -rf $(CURDIR)/debian/roundcube-core/usr/share/roundcube/plugins
-
-       # Symlink all that is in /usr/share/roundcube to /var/lib/roundcube
-       find debian/roundcube-core/usr/share/roundcube -maxdepth 1 -mindepth 1 | \
-       while read i; do \
-               if [ ! -L "$$i" ]; then \
-                 dh_link -proundcube-core "`echo "$$i" | sed -e s#debian/roundcube-core/##`" \
-                 "`echo "$$i" | sed -e s#debian/roundcube-core/usr/share/roundcube/#var/lib/roundcube/#`"; \
-               fi \
-       done
        # Install config files
        install -m 0640 $(CURDIR)/config/db.inc.php.dist $(CURDIR)/debian/roundcube-core/etc/roundcube/db.inc.php
        install -m 0640 $(CURDIR)/config/main.inc.php.dist $(CURDIR)/debian/roundcube-core/usr/share/roundcube
@@ -27,7 +12,7 @@ binary-install/roundcube-core::
        for c in $(CURDIR)/debian/roundcube-core/etc/roundcube/*.php; do \
                dh_link -proundcube-core etc/roundcube/$$(basename $$c) var/lib/roundcube/config/$$(basename $$c) ; \
        done
-       dh_link -proundcube-core etc/roundube/htaccess var/lib/roundcube/.htaccess
+       dh_link -proundcube-core etc/roundcube/htaccess var/lib/roundcube/.htaccess
 
        # Database related files
        # Install empty tables and updates for each db type