]> git.donarmstrong.com Git - unscd.git/blobdiff - debian/rules
Migrate to salsa (with donarmstrong.com as a backup)
[unscd.git] / debian / rules
index 413cdd5f2814ca78f056a586ebcb099fc1fa0fd1..29c7baf8cb84f795d7d7fab15290b1551b35a199 100755 (executable)
@@ -1,19 +1,28 @@
 #!/usr/bin/make -f
 
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+
+include /usr/share/dpkg/architecture.mk
+-include /usr/share/dpkg/buildtools.mk
+CC_FOR_BUILD ?= $(CC)
+
 %:
-       dh $@ --with systemd
+       dh $@
 
 override_dh_auto_clean:
        rm -f nscd
        dh_auto_clean
 
 override_dh_auto_build:
-       gcc $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+       $(CC_FOR_BUILD) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c -lsystemd
        help2man --name 'nscd which does not hang' \
                --include debian/help2man \
                --no-info \
                ./nscd > debian/unscd.man
        ln -fs unscd.man debian/nscd.man
+ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
+       $(CC) $(CFLAGS) $(LDFLAGS) -o nscd nscd.c
+endif
 
 override_dh_auto_install:
        install -d debian/unscd/usr/sbin/